Help

You don’t need to waste your time and money anymore.

Frequently Asked Questions

Install the plugin just like any other WordPress plugin and you will find this beautiful collection in your Elementor page builder’s widgets section.

To run Plugaddons Smoothly, you have atleast Elementor 2.9 version on your site. Otherwise our plugin will not work smoothly. We have no other option as Elementor changes a lot in their code base. To give better customer experience we are recommending you to use Elementor atleast 2.9 or above.

Yes, absolutely, no holds barred. Use it to bring colorful moments to your customers. And don’t forget to check out the pro version which is coming soon with extra features. 

Free or pro version, both comes with excellent support from us. However, pro users will get priority support. 

Yes, but there might be a few highly unlikely exceptions to be honest. If you’re that unlucky to get one of those incompatible themes in your basket, let us know and we will fix it.

Nope, these widgets are made to bring smiles even on your grandma’s face. So go ahead, grab a cup of coffee and start using Plugaddons from today.

As long as you are not modifying the plugin in a way to make it look like developed by you, there are no restrictions of any kind. Do whatever you want, build anything and make everyone happy as long as you’re playing fair.

Talk to Us

Got a widget suggestion? Want to request a new feature? Too excited to send us few cups of coffee? Well, whatever it is, let us know.